MP1900 TVS Up & Running - Mustang Boards


V6 Tech Forums For all your 3.8L and 4.0L needs!

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 09-01-2012, 05:48 PM
Nice Pony's Avatar
Junior Member
Thread Starter
 
Join Date: Jun 2011
Posts: 6
Default MP1900 TVS Up & Running

Got this intercooled MP1900 TVS up and running on my built 4.0SOHC. Runs great. Working on data logging to finish off the tune. Makes 11PSI with a 3.0" pulley and 14PSI with a 2.8" pulley.



Here's a link to the build:
http://www.mustangcollective.com/showthread.php?t=35934
Reply With Quote
  #2  
Old 05-12-2013, 10:18 AM
Nice Pony's Avatar
Junior Member
Thread Starter
 
Join Date: Jun 2011
Posts: 6
Default X-Charger SuperX TVS Video

Video from dyno tune. Mustang dyno so numbers a bit low:

Last edited by Nice Pony; 05-12-2013 at 10:45 AM.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
TVs - Plasma vs. LCD vs. Standard Def whitethunder46 The Lounge 51 10-23-2006 07:44 AM
Son Of A @#%$&$!@#%&@$&!#%$&%*%&%#&$$#&! Rabbit The Lounge 11 09-01-2006 11:58 AM
h&r springs & c&c plates determined Suspension Talk 5 07-21-2006 07:35 AM
spike tvs autoroxs 1982 mustang 5.0 The Lounge 7 04-18-2006 08:45 PM
Help! Running a 4G Amp Wire? Foster98GT Show, Shine, and Tunes! 5 01-19-2006 06:36 PM


Tags
explorers, express, xcharger, xtreme

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 12:10 AM.