sequential taillights bad? - Mustang Boards


Show, Shine, and Tunes! Great talk on keeping your car looking the very best, discussing appearance items, and audio

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 10-03-2010, 05:41 PM
probiker427's Avatar
Senior Member
Thread Starter
 
Join Date: Mar 2009
Location: Mahwah, NJ
Posts: 1,062
Default sequential taillights bad?

I installed my sequential tail lights kit about a month and a half ago and they worked great. Last night I was driving home and my buddy was behind me and called me up and told me they werent working, which of course i didnt believe until i got home and saw it for myself. When i turn my blinker on or press the brake or hit the hazards, all 3 lights with go off at the same exact time, on both sides. Which i dont get because they are too separate modules. Which is why im asking could it be more then the modules and something like the whole harness for the tail lights. i got them from www.webelectricproducts.com if that matters and they offer a lifetime warranty for the kits but for some reason i dont think its the kit. If anyone can give me help id appreciate it.

Kyle
Reply With Quote
  #2  
Old 10-07-2010, 09:16 AM
TUFF 4.6's Avatar
"Just Add Foot"
 
Join Date: Dec 2007
Location: Richmond Va.
Posts: 2,250
Default

Easy stuff first 1) check bulbs 2) check wiring 3) check your flasher 4) call Web get new set.
Reply With Quote
  #3  
Old 10-07-2010, 09:20 AM
99MustangGT's Avatar
Senior Member
 
Join Date: May 2010
Location: Murfreesboro, TN
Posts: 616
Default

/\/\/\ Should be as simple as that.
Reply With Quote
  #4  
Old 10-07-2010, 09:34 AM
krazypony's Avatar
Senior Member
 
Join Date: Jul 2007
Location: Liberty, SC
Posts: 2,094
Default

I know one time when it got cold after I installed mine some time back, some moisture had gotten into them and then they were fine. I would check your bulbs maybe one is bad?
Reply With Quote
  #5  
Old 10-07-2010, 01:15 PM
probiker427's Avatar
Senior Member
Thread Starter
 
Join Date: Mar 2009
Location: Mahwah, NJ
Posts: 1,062
Default

no they all worked fine (bulbs), i think some water got into the module somehow, i sent them back just waiting for the new set.
Reply With Quote
  #6  
Old 10-07-2010, 01:28 PM
99MustangGT's Avatar
Senior Member
 
Join Date: May 2010
Location: Murfreesboro, TN
Posts: 616
Default

Hope it works out.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Problems at the shop installing sequential taillights 00mustanggt General Tech Forum 4 10-30-2007 10:03 PM
Mustang Sequential Taillights Kit - Splice-in (96-04) New Products New American Muscle Products 4 04-13-2007 12:42 PM
Dynamite Stick Sequential Taillights (2006+) New Products New American Muscle Products 2 06-21-2006 11:01 AM
Sequential Taillights for an '02 jblueguy General Tech Forum 4 01-19-2006 06:43 PM
Sequential taillights venom Videos 15 08-20-2005 06:24 AM


Tags
99, bad, cdc, gt, lights, mach, mustang, rims, sequential, sequentials, signs, smoked, tail, trouble, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

All times are GMT -7. The time now is 09:31 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.