2011 GT 5.0 - Bad Camshift or Sensor? - Mustang Boards


5.0L Tech There's no replacement for displacement.

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 06-24-2015, 07:04 AM
Junior Member
Thread Starter
 
Join Date: Jun 2015
Posts: 1
Default 2011 GT 5.0 - Bad Camshift or Sensor?

Check engine light started coming on, took to dealership and they can't figure out if it's a Sensor or the Camshaft. Seems to me if it was Camshaft I would have noticed some issues besides the light.
Reply With Quote
  #2  
Old 04-21-2016, 03:24 AM
Junior Member
 
Join Date: Apr 2016
Location: new york
Posts: 11
Default

Its a sensor trouble and nothing special yet
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Could have been bad....really bad! Slither The Lounge 8 05-08-2010 12:01 AM
Idle air intake sensor DarkSith General Tech Forum 1 04-10-2006 11:07 AM
Oxygen sensor replacement? mac0021 General Tech Forum 1 10-11-2005 04:17 PM
Mass air sensor...how u clean?? NoKturnaL The Lounge 7 06-09-2005 10:26 AM
stock MAF sensor mods? stanger00 General Tech Forum 6 11-25-2004 09:52 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

All times are GMT -7. The time now is 12:20 PM.