charging problem 95 GT stang - Mustang Boards


5.0L Tech There's no replacement for displacement.

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 04-18-2012, 08:16 AM
Junior Member
Thread Starter
 
Join Date: Apr 2012
Posts: 5
Default charging problem 95 GT stang

WELL HERE IT GOES IN THE MORNING MY CAR SLOWLY LOOSES ITS CHARGE GOES FROM ABOUT 12 AMPS TO 10 ,9, 8 IN ABOUT 10 MILES BUT WHEN I DRIVE HOME IN THE AFTERNOON IT CHARGES AT 14 OR SO CHANGED THE ALTENATOR LAST NIGHT KILLED THE BATTERY THIS MORN ON THE WAY TO WORK
Reply With Quote
  #2  
Old 04-18-2012, 05:03 PM
Junior Member
Thread Starter
 
Join Date: Apr 2012
Posts: 5
Default

Quote:
Originally Posted by tony m View Post
WELL HERE IT GOES IN THE MORNING MY CAR SLOWLY LOOSES ITS CHARGE GOES FROM ABOUT 12 AMPS TO 10 ,9, 8 IN ABOUT 10 MILES BUT WHEN I DRIVE HOME IN THE AFTERNOON IT CHARGES AT 14 OR SO CHANGED THE ALTENATOR LAST NIGHT KILLED THE BATTERY THIS MORN ON THE WAY TO WORK
well i have an update found that the positive battery cable clamp
was cracked so well see in the morning
Reply With Quote
  #3  
Old 04-19-2012, 06:30 AM
Junior Member
Thread Starter
 
Join Date: Apr 2012
Posts: 5
Default got it fixed

it was the cracked battery cable clamp ,thanks for the help not i fixed it my self i hope this will help some one else in the future

Last edited by tony m; 04-19-2012 at 06:32 AM.
Reply With Quote
  #4  
Old 05-04-2012, 09:56 AM
Junior Member
Thread Starter
 
Join Date: Apr 2012
Posts: 5
Talking

well that wasn`t the problem it was the battery light ,so when you turn the key on the battery light should turn on if not pull the dash cluster and replace the light or switch it with another bulb i hope this helps good luck!
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
s/charging or not smile7z Power Adders 8 11-14-2007 08:56 AM
Charging Problems!!!HELLLLP!!!! Foster98GT 5.0L Tech 4 07-08-2007 07:32 PM
Charging issues with 02 GT tableof_5 Modular 4.6L Tech 6 06-21-2006 04:18 PM
5.0 Charging Nightmare 03MustanGT 5.0L Tech 7 05-20-2006 10:09 PM
Having Charging Problems..... jeredan2003 Modular 4.6L Tech 13 03-29-2006 12:39 PM


Tags
08, 1995, 20, 95, amps, battery, cable, charging, gt, issues, mustang, positive, problem, pulling, tonyms

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -7. The time now is 06:37 PM.